Shake~Shake!

I want to use the flash light as my new word.

There was a small discussion of arduino direct by Wolfgang last Friday night in POD studio. Big thanks to Wolfgang!  I enjoy the moment, everyone around the table to do the arduino!

Firstly, I try to use the sparkle-skirt code to make the motion sensor code work. But, It never light! And I try to use other people`s board which can light! That means I need to resew the board and motion sensor again!

Image

Image

Thank you my fellow– Lance to makes some notes in my paperboard which let me know the meaning of different parts. And thanks to dear May to help me together to make a quick resew!

Image  GIF!!!

Finally, Shake~Shake!

Here is the vedio address in vimeo:

https://vimeo.com/75270227

Problem with acceleration.

Hi all!

This weeks challenge was a tough one! It took me a while to figure out what I was doing. The code was uploading fine once my computer found “Leonardo” 😛

However, it seemed that no amount of shaking was going to light up any LED’s on this cardboard. My stitched weren’t the best or tightest however I knew that the connection was strong from last class.  It wasn’t until I spoke to some of my classes that I realized the “Thresh-hold” was set too high and that if I dropped it down to a low number it would make the sensor very sensitive.  Below are photos and videos of the LED lighting up! 😀 Finally!

Screen Shot 2013-09-22 at 10.02.05 PM

IMG_2489

IMG_2490These are some ugly stitches 😀

if we move..

Hi,

I started with connecting an RGB LED light to my sewed Flora board.

Then I checked the LED with floratest, to see if my connection is right or not.. and it lighted up!

IMG_2094

Then I searched for the sparkling skirt’s code on adafruit and found it, then pasted it.

However, when I tried to upload the code, I got several “serial port COM4 is already in use” errors unfortunately.. Plugging out and then in again worked somehow and I also restarted the Flora.. But it makes me anxious not to know whats going on indeed. Anyway, I uploaded the code successfully and animated the code..

Important notice: move_threshold is quite important! I forgot to change it to 5 from 45 and I had problems with lighting up the LEDs.. Then thanks to Wolfgang, I understood what I forgot..

Here is the video

http://www.youtube.com/watch?v=_KsDC2GXOeY

here is the code

accelarator sensor 1

 

and I changed the colors to my favorite colors..

here is the code and my favorite colors video:

accelarator sensor changed colors

http://www.youtube.com/watch?v=Jr1DS70xIQE

Actually I was planning to change the codes in a way that I can match different colors with different movements.. Such as going left = blue, going right = red.. And I thought that the thing that Becky taught at the class -regarding changing “if” codes- would be helpful, but I was confused with the codes.. I hope I can get it this week.

Chameleon Scarf test

I ended up doing the Chameleon Scarf demo since I had sewn in the Flora color sensor. I added and sewed in another LED so it can register and show the color the sensor read. The connection was strong, and the light was able to pick up 2 out of the 5 test. Some of colors weren’t strong enough for the sensor to register and convert the colors into.

I will try to work on the accelerator, since it won’t register any data now. I’m trouble shooting.

here is the screen shot of code for the Chameleon scarf.

Screen Shot 2013-09-20 at 5.33.40 PM

Here are the successful test from running the program. I did understand a bit more of the conversations. Like sum can be written like + .. we learned this during class, but it clicked more during this test run.

DSC_0306 DSC_0307 DSC_0309

: )

NeoPixel “Switch” Up

Fun with the NeoPixels

I didn’t get too fancy with the NeoPixels but I did try to get all of mine connected in series.  Unfortunately I could only get the first one to work after hooking all that up.  I double checked all the connections and everything seemed lined up correctly.  + to + and – to – and all the arrows pointing in a row.  I decided it must be a jumper wire so I unhooked the three additional NeoPix that I’d connected to the functioning one and began connecting them out one at a time (note to self this is probably a good practice for the future) and when I didn’t get that 2nd one to light up I began swapping jumpers.

Image

I totally lucked out that the first one I tried seemed to be faulty.  This is the second jumper wire I’ve discovered like this and I’m wondering if with the multimeter I could test the wires for continuity.  (I set the jumpers aside but tied them in a loose knot so I know not to use them unless I figure out how to fix them.)

Image

I began switching numbers around and was able to figure out what all the parameters did.  First it displays each specified color at the brightness determined on the scale of 0 to 255 for a time determined by the 4th number in each series.  When I made the number smaller the delay was a shorter time.  (Not sure what unit of time this number represents.  I assumed it was milliseconds but it seem longer than this.)

Image

I was confused by the difference between rainbow and rainbow cycle.  I changed the parameters and deleted one and then the other line.  It seems like the cycle is a longer smoother thing.  The number which follows seems to make it happen faster or slower.

I decided to try adding the switch to my device so I could turn it on and off while I was rewriting code without plugging and unplugging the USB cable.  The switch worked but I got this error message on my computer.

Image

I’m not sure why adding a switch would cause the whole system to draw more power.  I noticed that in the Getting Started with Arduino book there’s a resister included in the switch circuit.  Maybe that’s why?  Need to find out more about this.

Image

Single LED was OK but strandtest.. not

After the last class which I couldn’t work my arduino stuff on my laptop, we tried to figure out the problem with Borris. Having tried many different things we achieved to make a blink -without knowing what we did- Then I thought all the problems are solved with my laptop and arduino.. But they aren’t.. I think the main problem is about “strandtest” because I imported strandtest manually to my library and it doesn’t work properly.

Here is my trials and failures:

First I started the Arduino application, and then connected the cords with a single RGB LED. Then I ran floratest and played with colors and delays.. Here are pics and videos:IMG_1975

IMG_1974

IMG_1968

http://www.youtube.com/watch?v=sNNbRuc3R_k&feature=youtu.be

Then, when I tried to make some trials with strandtest I couldn’t achieve it. Although I learned how to import things to library (we are not supposed to import files to the arduino file in program files, we should import them into the documents/arduino/libraries) And the second rule is legal file name, we should avoid using “-” in file names, but “_” works.

failure

Luces

Here is my first attempt, to simply figure out how to put them in order. I had a bad alligator clip, but found the bad one and continued.

 

first attempt

DSC_0302 DSC_0303

 

Here is my second attempt. I was happy to figure out setting up the second LED pretty fast by taking a look at the tutorials. I messed around with the colors, but had trouble getting it to change speeds or intervals. Fun trying to figure out how to read this.

second attempt

 

DSC_0304 DSC_0305luz

 

 

A very bright struggle.

Hi all,

I have never considered myself much of a techie guy so this process has been a challenge for me.

I began the experimentation process by going through the examples in the Arduino program, however, I could not get a set of two LED’s to turn on.

Frustrated; after a couple of tries, I decided to read this blog and see if that would help me in one way or another. I read and compared almost every set of code most of my classmates had played with (except Jung’s, I don’t own a toy I am willing to cut open, yet). 😀

Two of my failed attempts:

Screen Shot 2013-09-15 at 10.50.30 PM Screen Shot 2013-09-15 at 11.12.01 PM

That shade of orange might now be my least favorite color.

Screen Shot 2013-09-15 at 11.24.25 PM

finally, after what seemed an eternity, I was able to learn from Julia’s code! With her post I was not only able to make my own crowded little rainbow, but also play around with the speed at which the lights would change colors! Thank you Julia!

 IMG_2376

IMG_2382

Below you’ll find a link to my Instagram account where I posted the video of my little success.

http://instagram.com/minuscoco

Thank you!